Jump to content
GetaFever

Stained Glass Block Issue

Recommended Posts

Hey I don't have a lot of time right now, but I just wanted to bring this to the tech's attention. Basically if you choose a colored stained glass block on creative(e.g. green, purple, blue), It will inevitably turn white. Times vary, but it always ends up turning to a white stained glass block. 

 

That's pretty much all I know about it. I'll be doing a little testing and post more later, but that's all for now.

 

Thanks, GetaFever

Share this post


Link to post
Share on other sites

While placing stained glass for the dome, I was running into this when I destroyed blocks. After a quick test, it looks like this happens when you destroy any type of block with a stained glass block in your hand.

Share this post


Link to post
Share on other sites

Quick workaround; if you accidentally break a block, you can get it back with the pick block key, but you must then open your inventory, click on it, then put it back where it was.  If not, it will revert to white again.  This way you don't have to scroll through the inventory finding the color you need.

Share this post


Link to post
Share on other sites

Quick workaround; if you accidentally break a block, you can get it back with the pick block key, but you must then open your inventory, click on it, then put it back where it was.  If not, it will revert to white again.  This way you don't have to scroll through the inventory finding the color you need.

 

That's what I do, as well as simply keeping two of the same block in my hotbar, but it's still an unnecessary hassle that shouldn't be there.

Share this post


Link to post
Share on other sites

I first noticed this problem when we originally updated to 1.7, however I have not been able to reproduce this on S or P or on my own server. I haven't looked into it in a while, but I was at a loss before to it's cause. Originally it affected almost all the new 1.7 blocks and it seemed to simply strip the color for them. Currently it seems to only be happening on the stained glass and kinda unfortunately means its low priority for me =\ If anyone happens to figure out any more info, please do let me know.

Share this post


Link to post
Share on other sites

I first noticed this problem when we originally updated to 1.7, however I have not been able to reproduce this on S or P or on my own server. I haven't looked into it in a while, but I was at a loss before to it's cause. Originally it affected almost all the new 1.7 blocks and it seemed to simply strip the color for them. Currently it seems to only be happening on the stained glass and kinda unfortunately means its low priority for me =\ If anyone happens to figure out any more info, please do let me know.

I'd love to try and help out, but unfortunately, 99.9% of the commands I'd need to use are blocked for whatever reason.

Share this post


Link to post
Share on other sites

I'd love to try and help out, but unfortunately, 99.9% of the commands I'd need to use are blocked for whatever reason.

They block stuff like /version and other things to prevent users from getting server info which could potentially be harmful. We had /plugins unblocked and now it alerts staff members whenever it is ran, but it would be hard to do similar to unblock other commands.

Share this post


Link to post
Share on other sites

They block stuff like /version and other things to prevent users from getting server info which could potentially be harmful. We had /plugins unblocked and now it alerts staff members whenever it is ran, but it would be hard to do similar to unblock other commands.

I understand that is their own reasoning behind it, but my point is we can't help if we don't have the commands we need to do so.

Share this post


Link to post
Share on other sites

Sorry for necroposting, but this is still an issue on Creative.

 

It was a bug in WorldEdit, which I fixed back in September, and it was pulled into the main WorldEdit branch on October 8th.

 

Updating WorldEdit to a build after Oct.8 (Build #3307 or greater) will fix this issue.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...